解决R语言安装包时出现package '' is not available(for R version 3.6.1)的问题

在安装R语言的一些包时,常常会出现package ‘’ is not available的错误,这里主要针对R 3.6.1的版本。对于R 3.5及其以下的版本,可以参考 https://blog.csdn.net/yepeng2007fei/article/details/78112557

Bioconductor的当前版本是版本3.9;它可以与R版本3.6.0配合使用。通过以下命令,使用BiocManager进行R包的安装。BiocManager::install()中填写包的名称,例如BiocManager::install(“survcomp”)。

1
2
3
if (!requireNamespace("BiocManager", quietly = TRUE))
install.packages("BiocManager")
BiocManager::install()